<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head ><link rel="stylesheet" type="text/css" href="http://cdn1.linuxroutes.com/wp-content/cache/minify/bb0d7.css" media="all" />

<meta charset="UTF-8" />
<title>How to create custom AMI in AWS - UX Techno</title><meta name="viewport" content="width=device-width, initial-scale=1" />

<!-- This site is optimized with the Yoast SEO plugin v4.7 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Amazon Machine Image (AMI) gives the information required to launch an instance.This tutorial is all about how to create custom AMI in AWS."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://linuxroutes.com/create-custom-ami-aws/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to create custom AMI in AWS - UX Techno" />
<meta property="og:description" content="Amazon Machine Image (AMI) gives the information required to launch an instance.This tutorial is all about how to create custom AMI in AWS." />
<meta property="og:url" content="http://linuxroutes.com/create-custom-ami-aws/" />
<meta property="og:site_name" content="UX Techno" />
<meta property="article:publisher" content="https://www.facebook.com/uxtechno/" />
<meta property="article:tag" content="custom ami in aws" />
<meta property="article:tag" content="how to create custom ami in aws" />
<meta property="article:section" content="AWS" />
<meta property="article:published_time" content="2017-05-08T08:58:57+05:30" />
<meta property="article:modified_time" content="2017-05-08T09:13:52+05:30" />
<meta property="og:updated_time" content="2017-05-08T09:13:52+05:30" />
<meta property="og:image" content="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Amazon Machine Image (AMI) gives the information required to launch an instance.This tutorial is all about how to create custom AMI in AWS." />
<meta name="twitter:title" content="How to create custom AMI in AWS - UX Techno" />
<meta name="twitter:image" content="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="UX Techno &raquo; Feed" href="http://linuxroutes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="UX Techno &raquo; Comments Feed" href="http://linuxroutes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="UX Techno &raquo; How to create custom AMI in AWS Comments Feed" href="http://linuxroutes.com/create-custom-ami-aws/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxroutes.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>






<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%7CRaleway%3A400%2C500%2C900&#038;ver=3.1' type='text/css' media='all' />




<script type="text/javascript">
var iworks_upprev = { animation: 'flyout', position: 'right', offset_percent: 75, offset_element: '#comments', css_width: 360, css_side: 5, compare: 'random', url_new_window: 0, ga_track_views: 1, ga_track_clicks: 1, ga_opt_noninteraction: 1, title: 'How to create custom AMI in AWS' };
</script>
<script type="text/javascript" src="http://cdn2.linuxroutes.com/wp-content/cache/minify/df983.js"></script>


<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"http:\/\/linuxroutes.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Press %s to Copy, %s to Paste","minimize":"Click To Expand Code"};
/* ]]> */
</script>
<script type="text/javascript" src="http://cdn2.linuxroutes.com/wp-content/cache/minify/8235f.js"></script>


<!--[if lt IE 9]>
<script type='text/javascript' src='http://cdn2.linuxroutes.com/wp-content/themes/genesis/lib/js/html5shiv.js'></script>
<![endif]-->



<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5905a2f175e4e1001109c132'></script>
<script type="text/javascript" src="http://cdn2.linuxroutes.com/wp-content/cache/minify/656ca.js"></script>

<link rel='https://api.w.org/' href='http://linuxroutes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxroutes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://cdn3.linuxroutes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='http://wp.me/p898Y2-F0' />
<link rel="alternate" type="application/json+oembed" href="http://linuxroutes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxroutes.com%2Fcreate-custom-ami-aws%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://linuxroutes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxroutes.com%2Fcreate-custom-ami-aws%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="http://linuxroutes.com/xmlrpc.php" />
<script async src=\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"ca-pub-2115389363872588\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\",
    enable_page_level_ads: true
  });
</script><meta name="yandex-verification" content="6193d1b1f3a55afa" />
<meta name="google-site-verification" content="TjeZFo_Yr27vdEvU4NFS-4XmzWweCLcu-w_igc2ORm4" /><style type="text/css" media="screen"> .simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #eeeeee !important; border-radius: 0px; color: #222222 !important; border: 0px #ffffff solid !important; font-size: 28px; padding: 14px; }  .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #222222 !important; border-color: #ffffff !important; color: #ffffff !important; }  .simple-social-icons ul li a:focus { outline: 1px dotted #222222 !important; }</style><link rel="icon" href="http://cdn1.linuxroutes.com/wp-content/uploads/2016/12/cropped-uxtechno-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://cdn3.linuxroutes.com/wp-content/uploads/2016/12/cropped-uxtechno-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://cdn1.linuxroutes.com/wp-content/uploads/2016/12/cropped-uxtechno-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://cdn3.linuxroutes.com/wp-content/uploads/2016/12/cropped-uxtechno-270x270.jpg" />
			<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.

Click the help icon above to learn more.
*/
.box_below {
	width: 90%;
	padding: 10px;
  -webkit-border-radius: 70px
	-moz-border-radius:70px;
	border-radius: 70px;
	border:8px solid #000000;
	background-color:#E3E3D5;
	-webkit-box-shadow: #B3B3B3 49px 49px 49px;
	-moz-box-shadow: #B3B3B3 49px 49px 49px; 
	box-shadow: #B3B3B3 49px 49px 49px;
  margin-left: 0px;
 padding-left: 30px;
}
.box_below:hover {
	background:#C8E3B6;
	color: #3a7999;
	box-shadow: inset 0 0 0 3px #3a7999;
}
.home .box_below {
	display: none;
}
.archive .box_below {
	display: none;
}
.home .entry-pagination.pagination {
	display: none;
}

			</style>
		<style type="text/css">
#upprev_box{bottom:5px;width:360px;right:5px;display:block;right:-415px;display:block;}
 </style>
</head>
<body class="post-template-default single single-post postid-2542 single-format-standard content-sidebar magazine-pro-orange" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://linuxroutes.com/">UX Techno</a></p><p class="site-description" itemprop="description">Platform for learning UNIX &amp; LINUX technologies</p></div><div class="widget-area header-widget-area"><section id="text-4" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- nw -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2115389363872588"
     data-ad-slot="7687498555"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></section>
<div class="awd-hidden-desktop"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://linuxroutes.com/" role="search"><meta itemprop="target" content="http://linuxroutes.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search the site ..." /><input type="submit" value="Search"  /></form></div></section>
</div></div></div></header><nav class="nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-menu-1" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-29" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-29"><a href="http://linuxroutes.com/" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-1468" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1468"><a href="http://linuxroutes.com/post-index/" itemprop="url"><span itemprop="name">Post Index</span></a></li>
<li id="menu-item-924" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-924"><a href="http://linuxroutes.com/contact-us/" itemprop="url"><span itemprop="name">Contact US!</span></a></li>
<li id="menu-item-915" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-915"><a href="http://linuxroutes.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-2542 post type-post status-publish format-standard has-post-thumbnail category-aws tag-custom-ami-in-aws tag-how-to-create-custom-ami-in-aws entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">How to create custom AMI in AWS</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-05-08T08:58:57+00:00">May 8, 2017</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://linuxroutes.com/author/admin/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">admin</span></a></span> <span class="entry-comments-link"><a href="http://linuxroutes.com/create-custom-ami-aws/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><div class="share-before share-filled share-small" id="share-before-2542"><div class="googlePlus" id="googleplus-before-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Share"></div><div class="facebook" id="facebook-before-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Share"></div><div class="twitter" id="twitter-before-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Tweet"></div><div class="pinterest" id="pinterest-before-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Pin"></div><div class="linkedin" id="linkedin-before-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Share"></div><div class="stumbleupon" id="stumbleupon-before-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Share"></div></div>
			<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#googleplus-before-2542').sharrre({
										  share: {
										    googlePlus: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('googlePlus');
										  }
										});
$('#facebook-before-2542').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-before-2542').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});
$('#pinterest-before-2542').sharrre({
										  share: {
										    pinterest: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  pinterest: { media: 'http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png', description: 'How to create custom AMI in AWS' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('pinterest');
										  }
										});
$('#linkedin-before-2542').sharrre({
										  share: {
										    linkedin: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('linkedin');
										  }
										});
$('#stumbleupon-before-2542').sharrre({
										  share: {
										    stumbleupon: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('stumbleupon');
										  }
										});

				});
		</script><hr />
<p>Amazon Machine Image (AMI) gives the information required to launch an instance, which is a virtual server in the cloud. There are multiple AMI available within the AWS, But what if we want to create custom AMI in AWS. This tutorial is all about how to create custom AMI in AWS.<a href="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png"><img src="http://cdn3.linuxroutes.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1-300x200.png" data-attachment-id="2558" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws-2/" data-orig-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png" data-orig-size="576,384" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS" data-image-description data-medium-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1-300x200.png" data-large-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png" class=" wp-image-2558 alignright" alt="create custom AMI in AWS" width="177" height="118" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1-300x200.png 300w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png 576w" sizes="(max-width: 177px) 100vw, 177px"><noscript><img data-attachment-id="2558" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws-2/" data-orig-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png" data-orig-size="576,384" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS" data-image-description="" data-medium-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1-300x200.png" data-large-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png" class=" wp-image-2558 alignright" src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1-300x200.png" alt="create custom AMI in AWS" width="177" height="118" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1-300x200.png 300w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png 576w" sizes="(max-width: 177px) 100vw, 177px" /></noscript></a></p>
<hr />
<p>The following are the main reasons to create custom AMI in AWS:</p>
<div class="itemizedlist">
<ul class="itemizedlist" type="disc">
<li class="listitem">You need pre-bundle packages instead of installing them after the instance boots.</li>
<li class="listitem">You need to control the timing of package updates to provide a consistent base image for your layer.</li>
<li class="listitem">You need instances—LOAD-BASED instances in particular—to boot as quickly as possible.</li>
</ul>
<p>Once  you are ready with your customised EC2 instance. We can create custom AMI in AWS so that it can be used to launch as many required instances based on requirement. As an example we are going to create custom AMI in AWS for our web server.</p>
<!-- Quick Adsense WordPress Plugin: http://quicksense.net/ -->
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- linux -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-2115389363872588"
     data-ad-slot="3914490951"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

</div>
<h2><span style="color: #ff6600;">Steps to create custom AMI in AWS:</span></h2>
<ol>
<li>Login to AWS console</li>
<li>Goto EC2 dashboard and select the instance for which you want to create custom AMI.</li>
<li>Then goto Action button and select Image-&gt; Create image as below:<a href="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS.png"><img src="http://cdn3.linuxroutes.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS.png" data-attachment-id="2543" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws/" data-orig-file="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS.png" data-orig-size="1360,361" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS" data-image-description data-medium-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-300x80.png" data-large-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1030x273.png" class="alignnone wp-image-2543 size-full" alt="create custom AMI in AWS" width="1360" height="361" srcset="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS.png 1360w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-300x80.png 300w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-768x204.png 768w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1030x273.png 1030w" sizes="(max-width: 1360px) 100vw, 1360px"><noscript><img data-attachment-id="2543" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws/" data-orig-file="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS.png" data-orig-size="1360,361" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS" data-image-description="" data-medium-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-300x80.png" data-large-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1030x273.png" class="alignnone wp-image-2543 size-full" src="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS.png" alt="create custom AMI in AWS" width="1360" height="361" srcset="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS.png 1360w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-300x80.png 300w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-768x204.png 768w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1030x273.png 1030w" sizes="(max-width: 1360px) 100vw, 1360px" /></noscript></a></li>
<li>In the next pop-up window system will ask for &#8220;<strong>Image name</strong>&#8221; and &#8220;<strong>Image description</strong>&#8220;. Also you can change the size of root volume if you want to change however in our case we are keeping the same as below. Click the &#8220;<strong>Create Image</strong>&#8221; button.<a href="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1.png"><img src="http://cdn3.linuxroutes.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1.png" data-attachment-id="2544" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws1/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1.png" data-orig-size="1070,538" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS1" data-image-description data-medium-file="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-300x151.png" data-large-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-1030x518.png" class="alignnone wp-image-2544 size-full" alt="create custom AMI in AWS" width="1070" height="538" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1.png 1070w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-300x151.png 300w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-768x386.png 768w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-1030x518.png 1030w" sizes="(max-width: 1070px) 100vw, 1070px"><noscript><img data-attachment-id="2544" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws1/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1.png" data-orig-size="1070,538" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS1" data-image-description="" data-medium-file="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-300x151.png" data-large-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-1030x518.png" class="alignnone wp-image-2544 size-full" src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1.png" alt="create custom AMI in AWS" width="1070" height="538" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1.png 1070w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-300x151.png 300w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-768x386.png 768w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS1-1030x518.png 1030w" sizes="(max-width: 1070px) 100vw, 1070px" /></noscript></a></li>
</ol>
<h3><span style="color: #ff6600;">How to check created Custom AMI.</span></h3>
<ol>
<li>To Check the status of AMI creation process Goto Images&#8211;&gt;AMIs. You will see pending status as below for some time.<a href="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3.png"><img src="http://cdn3.linuxroutes.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3.png" data-attachment-id="2547" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws3/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3.png" data-orig-size="1143,245" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS3" data-image-description data-medium-file="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-300x64.png" data-large-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-1030x221.png" class="alignnone wp-image-2547 size-full" alt="create custom AMI in AWS" width="1143" height="245" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3.png 1143w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-300x64.png 300w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-768x165.png 768w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-1030x221.png 1030w" sizes="(max-width: 1143px) 100vw, 1143px"><noscript><img data-attachment-id="2547" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws3/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3.png" data-orig-size="1143,245" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS3" data-image-description="" data-medium-file="http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-300x64.png" data-large-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-1030x221.png" class="alignnone wp-image-2547 size-full" src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3.png" alt="create custom AMI in AWS" width="1143" height="245" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3.png 1143w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-300x64.png 300w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-768x165.png 768w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS3-1030x221.png 1030w" sizes="(max-width: 1143px) 100vw, 1143px" /></noscript></a></li>
<li>Once the process is completed status will become as &#8220;Available&#8221;:<a href="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4.png"><img src="http://cdn3.linuxroutes.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4.png" data-attachment-id="2548" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws4/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4.png" data-orig-size="1066,118" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS4" data-image-description data-medium-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-300x33.png" data-large-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-1030x114.png" class="alignnone size-full wp-image-2548" alt="create custom AMI in AWS" width="1066" height="118" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4.png 1066w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-300x33.png 300w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-768x85.png 768w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-1030x114.png 1030w" sizes="(max-width: 1066px) 100vw, 1066px"><noscript><img data-attachment-id="2548" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws4/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4.png" data-orig-size="1066,118" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS4" data-image-description="" data-medium-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-300x33.png" data-large-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-1030x114.png" class="alignnone size-full wp-image-2548" src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4.png" alt="create custom AMI in AWS" width="1066" height="118" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4.png 1066w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-300x33.png 300w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-768x85.png 768w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS4-1030x114.png 1030w" sizes="(max-width: 1066px) 100vw, 1066px" /></noscript></a></li>
<li>Also in the snapshot within in the EBS (ELASTIC BLOCK STORE), you can able to see the snapshot being created for the AMI image created by us.<a href="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5.png"><img src="http://cdn3.linuxroutes.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5.png" data-attachment-id="2549" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws5/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5.png" data-orig-size="1355,243" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS5" data-image-description data-medium-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-300x54.png" data-large-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-1030x185.png" class="alignnone wp-image-2549 size-full" alt="create custom AMI in AWS" width="1355" height="243" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5.png 1355w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-300x54.png 300w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-768x138.png 768w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-1030x185.png 1030w" sizes="(max-width: 1355px) 100vw, 1355px"><noscript><img data-attachment-id="2549" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws5/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5.png" data-orig-size="1355,243" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS5" data-image-description="" data-medium-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-300x54.png" data-large-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-1030x185.png" class="alignnone wp-image-2549 size-full" src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5.png" alt="create custom AMI in AWS" width="1355" height="243" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5.png 1355w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-300x54.png 300w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-768x138.png 768w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS5-1030x185.png 1030w" sizes="(max-width: 1355px) 100vw, 1355px" /></noscript></a></li>
</ol>
<h3><span style="color: #ff6600;">How to Launch custom AMI in AWS.</span></h3>
<p>Now in case in future if you would like to launch this customised AMI, just goto EC2 dashboard select Launch Instance. And you can able to see our custom AMI created under &#8220;My AMIs&#8221; tab.<a href="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6.png"><img src="http://cdn3.linuxroutes.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6.png" data-attachment-id="2550" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws6/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6.png" data-orig-size="1339,508" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS6" data-image-description data-medium-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-300x114.png" data-large-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-1030x391.png" class="alignnone size-full wp-image-2550" alt="create custom AMI in AWS" width="1339" height="508" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6.png 1339w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-300x114.png 300w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-768x291.png 768w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-1030x391.png 1030w" sizes="(max-width: 1339px) 100vw, 1339px"><noscript><img data-attachment-id="2550" data-permalink="http://linuxroutes.com/create-custom-ami-aws/create-custom-ami-in-aws6/" data-orig-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6.png" data-orig-size="1339,508" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="create custom AMI in AWS6" data-image-description="" data-medium-file="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-300x114.png" data-large-file="http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-1030x391.png" class="alignnone size-full wp-image-2550" src="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6.png" alt="create custom AMI in AWS" width="1339" height="508" srcset="http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6.png 1339w, http://cdn3.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-300x114.png 300w, http://cdn2.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-768x291.png 768w, http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS6-1030x391.png 1030w" sizes="(max-width: 1339px) 100vw, 1339px" /></noscript></a>Once you select this AMI , it will get launched at the end of the process.</p>

<!-- Quick Adsense WordPress Plugin: http://quicksense.net/ -->
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- nw -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2115389363872588"
     data-ad-slot="7687498555"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>So this is how we can create custom AMI in AWS.</p>

<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div><div class="share-after share-filled share-small" id="share-after-2542"><div class="googlePlus" id="googleplus-after-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Share"></div><div class="facebook" id="facebook-after-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Share"></div><div class="twitter" id="twitter-after-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Tweet"></div><div class="pinterest" id="pinterest-after-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Pin"></div><div class="linkedin" id="linkedin-after-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Share"></div><div class="stumbleupon" id="stumbleupon-after-2542" data-url="http://linuxroutes.com/create-custom-ami-aws/" data-urlalt="http://wp.me/p898Y2-F0" data-text="How to create custom AMI in AWS" data-title="Share"></div></div>
			<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#googleplus-after-2542').sharrre({
										  share: {
										    googlePlus: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('googlePlus');
										  }
										});
$('#facebook-after-2542').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-after-2542').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});
$('#pinterest-after-2542').sharrre({
										  share: {
										    pinterest: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  pinterest: { media: 'http://cdn1.linuxroutes.com/wp-content/uploads/2017/05/create-custom-AMI-in-AWS-1.png', description: 'How to create custom AMI in AWS' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('pinterest');
										  }
										});
$('#linkedin-after-2542').sharrre({
										  share: {
										    linkedin: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('linkedin');
										  }
										});
$('#stumbleupon-after-2542').sharrre({
										  share: {
										    stumbleupon: true
										  },
										  urlCurl: 'http://linuxroutes.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('stumbleupon');
										  }
										});

				});
		</script><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://linuxroutes.com/create-custom-ami-aws/"
    dc:identifier="http://linuxroutes.com/create-custom-ami-aws/"
    dc:title="How to create custom AMI in AWS"
    trackback:ping="http://linuxroutes.com/create-custom-ami-aws/trackback/" />
</rdf:RDF>-->
</div><div><h3>You may like:</h3><ul><li><a href="http://linuxroutes.com/setting-up-wordpress-on-amazon-aws-ec2/" rel="bookmark" title="Permanent Link toSetting up WordPress on amazon aws EC2">Setting up WordPress on amazon aws EC2</a></li><li><a href="http://linuxroutes.com/how-to-login-to-aws-ec2-instance/" rel="bookmark" title="Permanent Link toHow to: login to AWS EC2 instance.">How to: login to AWS EC2 instance.</a></li><li><a href="http://linuxroutes.com/default-usernames-aws-for-logging-on-to-different-linux-distros-ec2-instance/" rel="bookmark" title="Permanent Link toDefault usernames in AWS for logging on to different Linux distros EC2 instance.">Default usernames in AWS for logging on to different Linux distros EC2 instance.</a></li><li><a href="http://linuxroutes.com/setup-aws-web-server/" rel="bookmark" title="Permanent Link toQuick way to setup AWS web server.">Quick way to setup AWS web server.</a></li><li><a href="http://linuxroutes.com/make-two-ec2-instances-connect-aws/" rel="bookmark" title="Permanent Link toHow to Make two Ec2 instances connect each other in AWS.">How to Make two Ec2 instances connect each other in AWS.</a></li><li><a href="http://linuxroutes.com/attach-and-mount-ebs-volume-to-ec2-linux-instance/" rel="bookmark" title="Permanent Link toHow To Attach And Mount EBS Volume To EC2 Linux Instance in AWS">How To Attach And Mount EBS Volume To EC2 Linux Instance in AWS</a></li><li><a href="http://linuxroutes.com/build-free-server-on-aws/" rel="bookmark" title="Permanent Link toStop wasting money on Practice Linux server ,Build free server on AWS in minutes.">Stop wasting money on Practice Linux server ,Build free server on AWS in minutes.</a></li></ul></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://linuxroutes.com/aws/" rel="category tag">AWS</a></span> <time class="entry-time" itemprop="datePublished" datetime="2017-05-08T08:58:57+00:00">May 8, 2017</time> </p><div class=box_below>
If this post helped you by any means, then Please <br>
Support Us! by making Payment <a href="http://linuxroutes.com/payment/"><u>Payment Link</u></a>.
<br>
Subscribe  For RSS Feed::<a href="http://feeds.feedburner.com/linuxroutesFeed"><u>Here</u></a>.
<br>Like my facebook page <a href="http://facebook.com/uxtechno"><u>FaceBook Page</u></a>
<br>Follow Us on Twitter::<a href="https://twitter.com/Linuxguru11"> <u>Twitter</u></a>
<br>Follow Us on YouTube::<a href="https://www.youtube.com/channel/UCrFMBrmRhC5iRzbGkPasxaw"> <u>YouTube</u></a>
</div></footer></article>
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/create-custom-ami-aws/#respond" style="display:none;">Cancel reply</a></small></h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=120390114&#038;postid=2542&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.9&#038;sig=6bccdaff16ba387902e4a02a8b43b00131cd90ca#parent=http%3A%2F%2Flinuxroutes.com%2Fcreate-custom-ami-aws%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><div class="awd-hidden-phone"><section id="search-2" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://linuxroutes.com/" role="search"><meta itemprop="target" content="http://linuxroutes.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search the site ..." /><input type="submit" value="Search"  /></form></div></section>
</div><section id="simple-social-icons-2" class="widget simple-social-icons"><div class="widget-wrap"><ul class="aligncenter"><li class="ssi-facebook"><a href="https://www.facebook.com/uxtechno/" ><svg role="img" class="social-facebook" aria-labelledby="social-facebook"><title id="social-facebook">Facebook</title><use xlink:href="http://linuxroutes.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-rss"><a href="http://feeds.feedburner.com/linuxroutesFeed" ><svg role="img" class="social-rss" aria-labelledby="social-rss"><title id="social-rss">RSS</title><use xlink:href="http://linuxroutes.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-stumbleupon"><a href="http://www.stumbleupon.com/stumbler/manmohanmirkar" ><svg role="img" class="social-stumbleupon" aria-labelledby="social-stumbleupon"><title id="social-stumbleupon">StumbleUpon</title><use xlink:href="http://linuxroutes.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-stumbleupon"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/Linuxguru11" ><svg role="img" class="social-twitter" aria-labelledby="social-twitter"><title id="social-twitter">Twitter</title><use xlink:href="http://linuxroutes.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li><li class="ssi-youtube"><a href="https://www.youtube.com/channel/UCrFMBrmRhC5iRzbGkPasxaw" ><svg role="img" class="social-youtube" aria-labelledby="social-youtube"><title id="social-youtube">YouTube</title><use xlink:href="http://linuxroutes.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-youtube"></use></svg></a></li></ul></div></section>
<section id="text-7" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Achivement</h4>
			<div class="textwidget"><a href="http://blog.feedspot.com/linux_blogs/" title="Linux Blogs"><img src="https://blog-cdn.feedspot.com/wp-content/uploads/2017/03/Linux_transparent_216px.png" ></img></a>
</div>
		</div></section>
<section id="text-5" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div>
    <style scoped>

        .button-success,
         .button-success {
            background: rgb(223, 117, 20); /* this is a green */
			margin: 0 auto;
        }
    </style>
        <button class="button-success pure-button"><a href="http://linuxroutes.com/payment/">Support Us! Make Payment! </a></button>
</div></div>
		</div></section>
<section id="text-8" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-2115389363872588"
     data-ad-slot="9403994159"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></section>
<section id="categories-2" class="widget widget_categories"><div class="widget-wrap"><h4 class="widget-title widgettitle">Categories</h4>
		<ul>
	<li class="cat-item cat-item-35"><a href="http://linuxroutes.com/aws/" >AWS</a> (8)
</li>
	<li class="cat-item cat-item-177"><a href="http://linuxroutes.com/extra/" >Extra</a> (1)
</li>
	<li class="cat-item cat-item-38"><a href="http://linuxroutes.com/hpunix/" >HPUNIX</a> (1)
</li>
	<li class="cat-item cat-item-92"><a href="http://linuxroutes.com/kali-linux/" >Kali Linux</a> (2)
</li>
	<li class="cat-item cat-item-8"><a href="http://linuxroutes.com/linux/" title="All Linux related posts">Linux</a> (70)
</li>
	<li class="cat-item cat-item-37"><a href="http://linuxroutes.com/linux/lvm-linux/" >LVM</a> (4)
</li>
		</ul>
</div></section>
<section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300by250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-2115389363872588"
     data-ad-slot="5441722558"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></section>
<!-- fixed widget --><div class="awd-visible-desktop"><section id="text-6" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Subscribes to Email Updates!!</h4>
			<div class="textwidget"><form style="border:1px solid #ccc;padding:3px;text-align:center;" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=linuxroutesFeed', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Enter your email address:</p><p><input type="text" style="width:140px" name="email"/></p><input type="hidden" value="linuxroutesFeed" name="uri"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Subscribe" /><p>Delivered by <a href="https://feedburner.google.com" target="_blank">FeedBurner</a></p></form></div>
		</div></section>
</div></aside></div></div><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- mycoupondeal_auto -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2115389363872588"
     data-ad-slot="3245230556"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>© 2016 UxTechno.  The content is copyrighted to Manmohan Mirkar and may not be reproduced on other websites.</p></div></footer></div>	<div style="display:none">
	</div>
<script>
    jQuery(document).ready(function () {
		jQuery.post('http://linuxroutes.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var F = new Function ( response );
			return( F() );
		});
    });
</script><script type="text/javascript">
var iworks_upprev = { animation: 'flyout', position: 'right', offset_percent: 75, offset_element: '#comments', css_width: 360, css_side: 5, compare: 'random', url_new_window: 0, ga_track_views: 1, ga_track_clicks: 1, ga_opt_noninteraction: 1, title: 'How to create custom AMI in AWS' };
</script>
<script type="text/javascript" src="http://cdn2.linuxroutes.com/wp-content/cache/minify/5b374.js"></script>

<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://cdn1.linuxroutes.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>



<script type="text/javascript" src="http://cdn2.linuxroutes.com/wp-content/cache/minify/b0c46.js"></script>

<script type='text/javascript'>
var q2w3_sidebar_options = new Array();
q2w3_sidebar_options[0] = { "sidebar" : "sidebar", "margin_top" : 10, "margin_bottom" : 10, "stop_id" : "colophon", "screen_max_width" : 350, "screen_max_height" : 0, "width_inherit" : false, "refresh_interval" : 1500, "window_load_hook" : false, "disable_mo_api" : false, "widgets" : ['text-6'] };
</script>



<script type="text/javascript" src="http://cdn2.linuxroutes.com/wp-content/cache/minify/403bd.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/linuxroutes.com\/wp-admin\/admin-ajax.php","nonce":"f64f4f872e","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/linuxroutes.com\/jugaad\/?redirect_to=http%3A%2F%2Flinuxroutes.com%2Fcreate-custom-ami-aws%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type="text/javascript" src="http://cdn2.linuxroutes.com/wp-content/cache/minify/428b3.js"></script>


		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=120390114&postid=2542&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.9&sig=6bccdaff16ba387902e4a02a8b43b00131cd90ca#parent=http%3A%2F%2Flinuxroutes.com%2Fcreate-custom-ami-aws%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=120390114&postid=2542&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.9&sig=6bccdaff16ba387902e4a02a8b43b00131cd90ca#parent=http%3A%2F%2Flinuxroutes.com%2Fcreate-custom-ami-aws%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201719.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.9',blog:'120390114',post:'2542',tz:'5.5',srv:'linuxroutes.com'} ]);
	_stq.push([ 'clickTrackerInit', '120390114', '2542' ]);
</script>
<div id="upprev_box"><h6>Read more:</h6><div class="upprev_excerpt"><h5><a href="http://linuxroutes.com/linux-system-information-commands/" rel="How to create custom AMI in AWS">Linux system information commands</a></h5><p>Linux system information commands. Some time we need to drill down in the system for getting the details about the...</p></div><a id="upprev_close" href="#" rel="close">Close</a></div></body></html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk
Content Delivery Network via cdn1.linuxroutes.com
Minified using disk

 Served from: linuxroutes.com @ 2017-05-08 15:25:40 by W3 Total Cache -->